Rubriky
Android

Android: problém se závislostmi

Zobrazuje se vám taková to hláška a nevíte jak problém vyřešit?

Zkuste nejprve aktualizovat všechny balíčky na nejnovější verzi. Pokud problém přetrvává, zkuste následující postup:

V root složce problémového projektu spustit příkaz:

gradlew app:dependencies > out.txt

V souboru out.txt najít řádky, které nemají šipku na nastavenou verzi SDK (u mne 28):

com.android.support:exifinterface:27.1.0
com.android.support:support-v4:26.1.0

Správně má být takhle:

com.android.support:support-v4:26.1.0 -> 28.0.0

tyto řádky se správnou verzí sdk přidat do build.gradle:

implementation 'com.android.support:exifinterface:28.0.0'
implementation 'com.android.support:support-v4:28.0.0'